Ubuntu ISO for Access Plus

Home Forums Azulle Access Plus Ubuntu ISO for Access Plus

  • Author
    Posts
  • #12499

    aristocrap
    Participant

    Got an Access Plus for its supposed compatibility with Ubuntu— saw a very recent Youtube video on installing Ubuntu on one, so I decided, why not…

    Installed Ubuntu 16.04 64-bit on it. No issues there. Started right up. Before I even started, I was well aware that this would void the warranty— let’s get that one out of the way once and for all.

    And so apart from the occasional mouse trails, I didn’t get any sound from the HDMI connection. I did mad research on fixing this issue all afternoon, but nothing worked.

    And so, I have a few questions:

    Should I have installed the 32-bit version instead?

    If there’s a product-specific Ubuntu ISO for the Access Plus, do I have to request it via e-mail to get it?

    Now let’s say all else fails, will the recovery download of Windows 10 on the support page fully reinstall the OS?

    I have no intention of getting rid of this unit just yet. If a fix/workaround comes along eventually, I’d like to get it.

  • #12600

    George
    Keymaster

    Hello,

    Thank you for choosing Azulle. We apologize for the inconvenience, I will be more then happy to assist you with the matter. Can we go ahead and repeat the process of installing Ubuntu on the unit by following this guide How to install Ubuntu and use this Ubuntu ISO Ubuntu ISO Download. If you need further assistance or have any questions or concerns please do not hesitate to contact us, We’re available mon-fri 9am – 5pm eastern time.

    Q. Should I have installed the 32-bit version instead?

    A. That will not be necessary with the provided link above.

    Q. If there’s a product-specific Ubuntu ISO for the Access Plus, do I have to request it via e-mail to get it?

    A. We do not have a specific Ubuntu version that can be provided to you, although we do have an ISO link of the Ubuntu file.

    Q. Now let’s say all else fails, will the recovery download of Windows 10 on the support page fully reinstall the OS?

    A. You always have the option to revert back to Windows Operating Systems.

    Kind Regards,
    George Gonzalez
    IT Department

    • This reply was modified 2 years, 3 months ago by   George.
  • #12831

    aristocrap
    Participant

    Thank you for the response.

    I followed the instructions, but still couldn’t get the HDMI audio to work.

    Did the same research, saw something about switching Pulse Audio to ALSA, but somehow, I couldn’t get it right.

    Could anybody post the proper Terminal commands to be entered right after the Ubuntu install? I’m still fairly new to Linux, though I’ve been using it for 3 years now, and I’ve never really had this much anguish over it.

  • #12901

    Azulle Support Team
    Keymaster

    Hello aristocrap,

    Did you use the ISO provided by us? If you installed the current Ubuntu version (17.04 Zesty Zapus) directly from the Canonical servers you will have an issue with the sound since the it is not fully supported by the kernel. By using our image you should be able to have the full experience out of the box. I suggest you to use Rufus ( https://rufus.akeo.ie ) to prepare the bootable USB, just make sure that you use “GPT partition scheme for UEFI “.

    Do not hesitate to contact us if you need further assistance.

    Thank you

  • #13706

    WolfWings
    Participant

    Heyas,

    So the issue with HDMI audio not working on Ubuntu 16.04 (or most versions you can download from Ubuntu) is actually because support for certain features of the chipset they use in the Access Plus (Cherry Trail Atom) was only added as of MUCH more recent Linux kernels.

    You’ll want to install the ‘mainline’ kernel, v4.11.x, with the most recent as of this forum post being v4.11.4 which (for Ubuntu) you can download here:

    http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.11.4/

    You’ll need these three:

    linux-headers-4.11.4-041104_4.11.4-041104.201706071003_all.deb
    linux-headers-4.11.4-041104-generic_4.11.4-041104.201706071003_amd64.deb
    linux-image-4.11.4-041104-generic_4.11.4-041104.201706071003_amd64.deb

    • This reply was modified 2 years, 2 months ago by   WolfWings.
  • #14467

    aristocrap
    Participant

    Bingo.

    I installed the Ubuntu 16.04 64-bit that I got from the Ubuntu website on my AAP, then updated the kernel to 4.11. HDMI audio works now, and is less buggy than the one provided by Azulle.

    Commands for updating the kernel can be found here: http://ubuntuhandbook.org/index.php/2017/05/install-4-11-kernel-ubuntu-linux-mint/

    There is only one problem: wifi doesn’t work after kernel update, so I’m doing more research on how to fix that.

    A lot of people hate the Unity desktop environment on Ubuntu, I personally can’t stand it, so I installed Cinnamon desktop to make it suck less. Then it got buggy again (mouse trails, text fields locking up, etc.). I suppose I’m going to have to keep trying until I get it right. I am NOT going back to Windows.

  • #14826

    ed.sutter
    Participant

    Hi,
    I’ve been wrestling with Ubuntu on my AAP for a while now.
    I have three units, all of which started with Windows-10, and I’ve overwritten with Ubuntu.
    On my first unit, I installed an .iso image that was available from Azulle, and that is the only unit that works for me.
    When I ordered the next two, that .iso image was no longer available and I was told to just run with off-the-shelf ubuntu.
    I’ve tried several different attempts (all by installing some .iso image on a USB stick and booting/installing from that device)…

    1. Just straight off-the-shelf ubuntu-16.04.2-desktop-amd64.iso
    2. Same ubuntu-16.04.2-desktop-amd64.iso, with 4.11 kernel upgrade.
    3. Same ubuntu-16.04.2-desktop-amd64.iso using the iorespin.sh script documented here:
    http://linuxiumcomau.blogspot.com.au/2017/06/customizing-ubuntu-isos-documentation.html

    4-6. Similar steps as above, but using lubuntu-17.04-desktop-amd64.iso.

    In each case, the system boots fine and runs; but my multi-media program runs (bidirectional audio and video) well for about 15 minutes and then a total freeze of the system (console, keyboard, remote access, etc…) that is only recoverable by power-cycle. This application runs fine on the original unit I bought that still has the original .iso image that I got from Azulle (but can’t find anymore). Plus I’ve run this on raspberry Pi, and several other linux boxes without fault. It is a multi-media application that is doing audio and video encode and decode using an external usb camera and usb audio device plus the HDMI for video out, so I’m suspicious that some Cherry Trail specific issue is causing this.

    The AAP that works reliably for me is running Ubuntu 16.04.2 LTS with kernel version “4.5.7-archermind-standard+”. While I’d rather run with mainline 4.11 (which supposedly has all the Cherry Trail patches) I’l take whatever I can get that allows my application to run.

    So, can I get the iso image that was available a few months ago?
    Or is there another way to build this to run reliably?
    Thanks,
    Ed

    • This reply was modified 2 years, 1 month ago by   ed.sutter.
  • #19051

    jtmcdermott
    Participant

    Will this image work with the Byte Plus? If not, is there a version for the byte plus?

  • #21569

    Azulle Support Team
    Keymaster

    Hello jtmcdermott,

    Will this image work with the Byte Plus?

    Yes, the Ubuntu 16.04 LTS ISO in out server will work in both Plus devices: Access Plus and Byte Plus.

    Do not hesitate to contact us if you need further assistance.

    Best regards.

  • #28914

    met5678
    Participant

    I just got an Access3 and noticed it came with Ubuntu 18.04. I’ve got a huge fleet (12) of Access Plus units, and wanted to know if there’s an ISO for Ubuntu 18.04 for them as well.

You must be logged in to reply to this topic.

Login here

Register here